Forums » Community Projects

TargetLess plugin

Apr 06, 2011 Pizzasgood link
Don't hit m, hit u. Goes directly to the scanner.
Apr 06, 2011 Trucegore link
Ah thanks, Still that window is a bit view blocking :) Thanks for the tip however.
Apr 17, 2011 jamesbuhls link
Is anybody else having trouble with Targetless? Anytime I install the TargetLess plugin, the game immediately crashes as soon as I launch from the station after logging in. If it matters I'm playing on a Linux-desktop loaded with Ubuntu 10.10 and have AutoRR, Calc, MAID, Trade Assistant, and NavComp installed.
Apr 17, 2011 draugath link
I'm not the creator of targetless, but I can ask a few questions that drazed will probably ask.
First, are you installing all of the plugins listed at the same time, or one at a time? If you were installing them all at the same time, try installing them one at a time to verify if it was actually targetless causing the problem.

Second, when the game crashes, if you could get the error message from the end of your ~/.vendetta/errors.log file, this will help identify where the problem is located.
Apr 17, 2011 drazed link
I haven't heard anyone else with crashing problems... also, I only run linux at home, so it's definitely the one I test most lol.

Draugath's questions are indeed what I would ask. Also try loading ONLY targetless and see if it still crashes.
Apr 22, 2011 jamesbuhls link
I loaded the game with only the TargetLess plugin installed and again the game immediately crashed when I launched from the station. I don't know what I'm looking for in the error log, so I copied the whole thing; the only stuff I removed was a few bars of chat. Error log follows:

Setting up signal handlers...archive returned 0
[Fri Apr 22 08:08:41 2011] Found driver: "OpenGL Reference GKGL driver". Type 5, Version 88.0. Load @0x08914db8
[Fri Apr 22 08:08:41 2011] Instantiate address: 0xb01550
[Fri Apr 22 08:08:41 2011] Found driver: "ALSA driver". Type 1, Version 10.1. Load @0x089171e8
[Fri Apr 22 08:08:41 2011] Instantiate address: 0xa50670
[Fri Apr 22 08:08:41 2011] Found driver: "Open Sound System driver". Type 1, Version 10.1. Load @0x0891a480
[Fri Apr 22 08:08:41 2011] Instantiate address: 0xd34210
ALSA initialized: 44100Hz, 16bit stereo, 92ms latency (16 periods x 256 samples)
[Fri Apr 22 08:08:41 2011] Loading intro progress thing.
[Fri Apr 22 08:08:42 2011] load_sample_ogg: Couldn't open sound/mission.updated.ogg (mission.updated)
[Fri Apr 22 08:08:42 2011] load_sample: Couldn't open sound/mission.updated.ogg (mission.updated)
[Fri Apr 22 08:08:42 2011] load_sample_ogg: Couldn't open sound/nfz.warning.enter.ogg (nfz.warning.enter)
[Fri Apr 22 08:08:42 2011] load_sample: Couldn't open sound/nfz.warning.enter.ogg (nfz.warning.enter)
[Fri Apr 22 08:08:42 2011] load_sample_ogg: Couldn't open sound/nfz.warning.leave.ogg (nfz.warning.leave)
[Fri Apr 22 08:08:42 2011] load_sample: Couldn't open sound/nfz.warning.leave.ogg (nfz.warning.leave)
/dev/js0: No such file or directory
Found joystick 'NextWindow Touchscreen (/dev/input/js0)'
numaxes = 2
numbuttons = 3
/dev/js1: No such file or directory
/dev/input/js1: No such file or directory
/dev/js2: No such file or directory
/dev/input/js2: No such file or directory
/dev/js3: No such file or directory
/dev/input/js3: No such file or directory
Found 1 joystick(s)
allocated pipes: 16->15, 18->17
Loaded plugin 'targetless'

caught SIGABRT; generating stack trace
fault address 0x824, c3108700, fffffffa
ss 0x0000007b 123
uesp 0xbfc2e69c -1077746020
efl 0x00200206 2097670
cs 0x00000073 115
eip 0x00c57416 12940310
err 0x00000000 0
trapno 0x00000000 0
eax 0x00000000 0
ecx 0x00000824 2084
edx 0x00000006 6
ebx 0x00000824 2084
esp 0xbfc2e69c -1077746020
ebp 0xbfc2e6a8 -1077746008
esi 0x0040ed3e 4255038
edi 0x00431ff4 4399092
ds 0xc05c007b -1067712389
es 0xffff007b -65413
fs 0xc05c0000 -1067712512
gs 0x00000033 51
brk> 00c57416: 00000006 bfc2e748 00000000 bfc2e6f0
- 00306e42: 00000000 00410e88 10e3eb40 0040ed3e
- 002fc8e8: 0828314a 08283123 00000144 082831ab
- 08098580: 09bcb008 00000000 bfc2e908 080a1a38
- 08095a7a: 00000000 08283663 bfc2e888 0034d488
- 080a1a38: 1095ed08 08283657 1092fe30 0817223b
- 080a1294: 10963f08 00349e5d bfc2e9f8 002b5ff4
- 080a0e38: 10960590 08283616 0000006d 00000002
- 080a0d78: 10953198 0828342c bfc2eb58 080b9723
- 080a0e38: 0ec4bb00 082809c8 00000002 08283616
- 080a0d78: 0ea66fd0 00000012 00000012 0034d488
- 080a0d78: 0ea84a58 0828345c 082809a2 0034ae70
- 080a312f: 0ea84a58 00000001 bfc2ed98 0824749d
- 080a3019: 0ffd99e8 09ba4e70 10976bd0 10976bd0
- 080a3019: 101df430 00000001 bfc2edc8 082357d8
- 080a3019: 101e7500 10ae9e08 0000000a 09ba4e00
- 080a3019: 1020dbb0 00000001 ffffffff 09ba4e00
- 080a3019: 102143d0 00000001 0e8e8e10 10976c30
- 0807d692: 09ba4e00 00000038 0034ae7b 0034ae70
- 0823a08b: 09ba4e00 10976bac 00000000 10976bc4
- 08248977: 09ba4e00 0000000a ffffffff 09ba4e00
- 0823a8f0: 09ba4e00 10976a74 ffffffff 00000088
- 08234df1: 09ba4e00 bfc2f114 bfc2f018 00349f33
- 08239407: 09ba4e00 08234dd0 bfc2f114 08236119
- 08239aef: 09ba4e00 08234dd0 bfc2f114 000001d4
- 08236e95: 09ba4e00 00000000 ffffffff 00000001
- 0825887a: 09ba4e00 00000028 00000000 00000000
- 0823a08b: 09ba4e00 10976a5c 00000002 10976a74
- 08248977: 09ba4e00 00000004 00000000 09ba4e00
- 0823a8f0: 09ba4e00 109768b8 00000000 00000030
- 08234df1: 09ba4e00 bfc2f454 0040fc5f 0040ff6a
- 08239407: 09ba4e00 08234dd0 bfc2f454 08264d28
- 08239aef: 09ba4e00 08234dd0 bfc2f454 00000018
- 08236e95: 09ba4e00 00000003 00000000 00000001
- 0825e4a6: 09ba4e00 00000003 00000000 00000000
- 080c4b9f: 09b78c60 bfc2fd4c 00000076 01e22108
- 080c8794: 09b78c60 bfc2fde0 00000005 bfc2fe30
- 081c29c2: 09b897a0 bfc2fe29 0000007d 00000000
- 081c2dd4: 09b897a0 4db17068 bfc321bc 00000001
- 081bf586: bfc321bc bfc30714 bfc30694 00000000
- 081bff54: bfc321bc 00000000 00000000 002881c1
- 08058f13: 08a4d098 00000001 42c80000 41200000
- 0805a0d6: 00000001 bfc328f4 00000000 00002000
- 0806359c: 08277394 00000000 bfc328c8 002efce7
- 002efce7: 080634b0 00000001 bfc328f4 08277394
Apr 25, 2011 draugath link
I've encountered similar behaviour in the past when updating plugins. I'll start the game, and then it crashes to the desktop as soon as the game loads. Usually restarting the game again clears up the problem. Are these crashes continuous, or are you removing targetless after it crashes?

Work flow example 1:
1) Install targetless
2) Run game
3) Game crashes
4) Remove targetless
5) Run game
6) Game runs without problem

Work flow example 2:
1) Install targetless
2) Run game
3) Game crashes
4) Run game
5) Game runs without problem
Apr 25, 2011 jamesbuhls link
I've actually done both of those flows. After the game crashes and I restart VO, Targetless works, except then it wreaks havoc with my keybinds. Perhaps one of the reasons for this is because I've remapped most of the keyboard so that nearly everything that isn't bound to the mouse can be done with the left hand.

The biggest problem is that Targetless kept changing the keybinds I had bound to my mouse; even after I removed Targetless, when I started the game all keybinds to the mouse would be cleared - every time, I'd launch from a station to start playing only to find that my mouse suddenly had no functions at all.

So yes, I've tried both of the flows you mentioned, and yes, it worked after it crashed once, but no, not all the problems went away. The only way I could get the game to stop clearing the keybinds from my mouse was to uninstall the game, delete the .vendetta directory, and do a full, clean install from scratch.
Apr 25, 2011 Eztarget link
Found what appears to be a bug. i set the number or roids listed to 20. Targetless only saves 20 then stops recording. if i change the list display to 9999 it starts recording again. i have a big screen to play on and just wanted a longer list to view then 6. seems to be a bug to me or maybe just my system.
anyone else experience this?

C-ya in Game

Apr 25, 2011 draugath link
jamesbuhls, I'm inclined to think that something else is going on not directly related to targetless. Targetless doesn't just hijack binds unless you go into /targetless and tell it to bind things. The recent patch has made it so that unknown binds are no longer removed from the wgaf.cfg, so the issue of targetless binds being removed if you remove targetless is no longer present.* I'm further stymied by the fact that you're the only person I'm aware of that has reported this problem.

I too run on linux, and aside from the occasional seg fault following a crash or restart, I don't have much issue. Most of my crashes are due to creating and fixing problems in my own plugins (I hate VO's IUP implementation).

I wish I could offer more assistance at this point in time, but I'm just not familiar enough with the client and it's ins-and-outs.

Good luck.

*This was a common complaint from people who had to remap a lot of binds whenever they removed plugins.
Apr 26, 2011 Pizzasgood link
Yeah, I'm also a longtime linux and targetless user and have never had that problem. I'm thinking there must be something else that is odd about your setup. It may not necessarily be that this something else is actually broken, just that it's different enough that it triggers a bug in targetless that nobody else sees.

Hopefully drazed can get you sorted.
May 16, 2011 Googie link
Awesome plugin! Thanks so much!
I am also using Ubuntu 10.10 and it crashed on me the first time I tried to launch from the station. Next time I ran vo the gui was different and there were no further problems. Works like a charm so far!
May 18, 2011 Googie link
When I use targetless in a station I get crashes... 9/10 times it will crash when launching from the station. It will always crash if I use targetless and then try to select a mission. Bad news is that mission is no longer available to me after I re-connect...
No problems if I use targetless while flying....
May 19, 2011 drazed link
"When I use targetless in a station I get crashes"

I've tried using /targetless in station, and doing various things in the interface, then selecting missions and/or launching and can't reproduce a crash on Arch64 linux... Can you be more specific? What are you doing with targetless in station? What missions are you selecting? etc...

May 20, 2011 Googie link
Thanks for response...
I primarily use targetless for checking where the various ore are located before I take a mission. Once I have a sector determined, I close targetless while in the station. So open targetless, click on Ores. Go through (usually) my entire list of sectors. I will click on the column with the ore in question to sort those at the top and then just go through sector by sector to determine which one I'll hit up for mining.

Usually at this time I will just exit the station and vo will close.

Twice now I have selected a mining mission (one for mining carbonic and one for mining some other low level ore) and then vo will close.

When I reconnect to vo the mission in particular is no longer available to select, and it isn't in my list of completed/aborted missions.

Hope this helps...

Using Ubuntu 10.10.

Love Targetless BTW...Thanks so much for the work...
Sep 27, 2011 drazed link
Targetless 1.7.13 released:

* android support, swipe list up/down change targets, swipe left/right to change lists, tap to pin/unpin
* target next/prev no longer jumps around after pin/unpin
* ore info will no longer get stuck/duplicated after appendiups is called successive times
* fix api.radarlock when pinned targets in radar range AND roid list exceeds max-list-size
* other minor bugs patched

WARNING: android support limited to tablets for now... Cannot (and will not) guarantee any functionality on a phone ;)
Sep 27, 2011 drazed link
oh, also forgot, some updates/fixes by draugath. To name a few:

* unroid patch (fix for re-selecting already scanned roids)
* addroid patch (no longer require duplicate internal scans to add a roid)
* fix a minor memory leak (related to above ore-stuck bug)
Oct 26, 2011 Crusader8389 link
One thing I'd really like to see in targetless is ability to point to roids out of range... i.e. note location of roids somehow and have a vector show up on screen to point ship where it needs to go to find that roid.
Oct 26, 2011 Pizzasgood link
Position data is not available to plugins, so I don't see that happening unless drazed adds a bunch of fancy image recognition code or something (which I think would have to be handled via a separate program).

RIP, /DisplayShipPos
Oct 28, 2011 drazed link
Actually pizza, it is possible to get relative positions using known roids and their distances, using trilateration. Similar to how GPS works. That said, I have no plans to do this anytime soon (if ever). If a roid is out of range, you need to fly in range to find it :p