Forums » Community Projects

"You cannot jettison thet type of cargo"

Jul 23, 2015 neon black link
Hey everybody,

I mine like crazy. I use autojett plugin all the time. Whenever I do, I get a constantly-repeating message that says "You cannot jettison that type of cargo" printed to my chatline over and over as I mine and it's annoying the shit out of me.

Does anyone have any idea why this occurs or how I might go about making it go away? Ive looked through MAID and Autojett .lua files and cannot find that print output, and ive even removed all ore from the jettison list on my MAID plugin thinking that was the culprit - to no avail.

Any help much appreciated!

-[TRI] Neon Black
Jul 23, 2015 Kierky link
Sometimes it happens when you're strip mining and autojett tries to jett nothing, a lag issue. Also happens when you're in a Trident with ships on it because you can't jettison ships.
Jul 24, 2015 VikingRanger link
Neon, are you around again?
Jul 25, 2015 vskye link
That message started popping up after the devs did one of the updates. I sent the plugin to Ray to take a look at it and he suggested a change or two.

I'll see if I can find the notes and post back here.
Jul 26, 2015 vskye link
Ok, here's a few of Rays suggestions.

Try adding this line somewhere in the AutoJett event action.

if(GetInventoryItemQuantity(itemid) > 0) then return end

Mainly it's to see if maybe you're doing JettisonSingle too many times for a given item, causing you to jettison an item that you no longer have.
Try putting it after line 37? Maybe the second JettisonSingle() is getting called.

I never did get this resolved though.
Jul 27, 2015 neon black link
Thank you very much vskye. I will implement that line into the plugin when I get a chance and let you know what happens.
Sep 01, 2015 vskye link
You get a chance to try this yet Neon?
Sep 02, 2015 Death Fluffy link
Is there any value to this system notification? Maybe we could just ask GS to take it out.
Sep 05, 2015 katofmine link
I tried and failed, vskye. I like Fluffy's idea.
Sep 14, 2015 abortretryfail link
If only it told us what "that type of cargo" was!
Sep 16, 2015 yodaofborg link
I think its a relic from after the fix for jettisoning engines n stuff. IIRC that was the error you got after the fix. So yeah, it could and should be removed totally.
Oct 01, 2015 abortretryfail link
This started happening after they fixed it so you could no longer jettison ships-as-cargo.
Nov 23, 2015 scham link
I fixed some bugs (e.g. "you cannot jettison that type of cargo" as well as some other glitches) from autojett and released new version as autojett_v2.
Nov 29, 2015 vskye link
Cool scham. Have a link?
Nov 30, 2015 scham link
@vskye -> AutoJett_v2: